# This file was automatically generated by Dist::Zilla::Plugin::ModuleBuild v5.013.
use strict;
use warnings;

use Module::Build 0.3601;


my %module_build_args = (
  "build_requires" => {
    "Module::Build" => "0.3601"
  },
  "configure_requires" => {
    "Module::Build" => "0.3601"
  },
  "dist_abstract" => "A plugin for writing RESTful apps with Dancer",
  "dist_author" => [
    "Alexis Sukrieh <sukria\@sukria.net>",
    "Franck Cuny <franckc\@cpan.org>"
  ],
  "dist_name" => "Dancer-Plugin-REST",
  "dist_version" => "0.11",
  "license" => "perl",
  "module_name" => "Dancer::Plugin::REST",
  "recommends" => {},
  "recursive_test_files" => 1,
  "requires" => {
    "Carp" => 0,
    "Dancer" => "1.3111",
    "Dancer::Plugin" => 0,
    "strict" => 0,
    "warnings" => 0
  },
  "script_files" => [],
  "test_requires" => {
    "Dancer::ModuleLoader" => 0,
    "Dancer::Test" => 0,
    "File::Spec" => 0,
    "HTTP::Headers" => 0,
    "IO::Handle" => 0,
    "IPC::Open3" => 0,
    "Test::More" => "0.88",
    "perl" => "5.006"
  }
);


my %fallback_build_requires = (
  "Dancer::ModuleLoader" => 0,
  "Dancer::Test" => 0,
  "File::Spec" => 0,
  "HTTP::Headers" => 0,
  "IO::Handle" => 0,
  "IPC::Open3" => 0,
  "Module::Build" => "0.3601",
  "Test::More" => "0.88",
  "perl" => "5.006"
);


unless ( eval { Module::Build->VERSION(0.4004) } ) {
  delete $module_build_args{test_requires};
  $module_build_args{build_requires} = \%fallback_build_requires;
}

my $build = Module::Build->new(%module_build_args);

$build->create_build_script;