# This Makefile.PL for re-engine-TRE was generated by
# inc::TREMakeMaker <self>
# and Dist::Zilla::Plugin::MakeMaker::Awesome 0.20.
# Don't edit it but the dist.ini and plugins used to construct it.

use strict;
use warnings;

use 5.010;

use ExtUtils::MakeMaker 6.30;



my %WriteMakefileArgs = (
  "ABSTRACT" => "TRE regular expression engine",
  "AUTHOR" => "\x{c6}var Arnfj\x{f6}r\x{f0} Bjarmason <avar\@cpan.org>",
  "BUILD_REQUIRES" => {},
  "CONFIGURE_REQUIRES" => {},
  "DISTNAME" => "re-engine-TRE",
  "EXE_FILES" => [],
  "LIBS" => [
    "-lintl"
  ],
  "LICENSE" => "perl",
  "NAME" => "re::engine::TRE",
  "OBJECT" => "tre/regcomp.o tre/regerror.o tre/regexec.o tre/tre-ast.o tre/tre-compile.o tre/tre-match-approx.o tre/tre-match-backtrack.o tre/tre-match-parallel.o tre/tre-mem.o tre/tre-parse.o tre/tre-stack.o tre/xmalloc.o TRE.o",
  "PREREQ_PM" => {},
  "TEST_REQUIRES" => {},
  "VERSION" => "0.09",
  "test" => {
    "TESTS" => "t/*.t"
  }
);


my %FallbackPrereqs = ();


unless ( eval { ExtUtils::MakeMaker->VERSION(6.63_03) } ) {
  delete $WriteMakefileArgs{TEST_REQUIRES};
  delete $WriteMakefileArgs{BUILD_REQUIRES};
  $WriteMakefileArgs{PREREQ_PM} = \%FallbackPrereqs;
}

delete $WriteMakefileArgs{CONFIGURE_REQUIRES}
  unless eval { ExtUtils::MakeMaker->VERSION(6.52) };

WriteMakefile(%WriteMakefileArgs);