The Perl Advent Calendar needs more articles for 2022. Submit your idea today!

Changes for version 0.013 - 2017-06-02

  • Compatibility
    • Work completely with ancient versions of LWP (6.00 to 6.03 inclusive), and don't fail the tests on earlier versions, just warn that put_json and patch_json won't work.

Modules

a very simple superclass for JSON HTTP messages
a subclass of HTTP::Request that understands JSON
a subclass of HTTP::Response that understands JSON
use JSON natively with LWP objects
a subclass of LWP::UserAgent that understands JSON