# This file was automatically generated by Dist::Zilla::Plugin::ModuleBuild v6.015.
use strict;
use warnings;

use Module::Build 0.28;


my %module_build_args = (
  "build_requires" => {
    "Module::Build" => "0.28"
  },
  "configure_requires" => {
    "Module::Build" => "0.28"
  },
  "dist_abstract" => "a maniac download accelerator.",
  "dist_author" => [
    "Shlomi Fish <shlomif\@cpan.org>"
  ],
  "dist_name" => "App-ManiacDownloader",
  "dist_version" => "0.0.13",
  "license" => "mit",
  "module_name" => "App::ManiacDownloader",
  "recursive_test_files" => 1,
  "requires" => {
    "AnyEvent::FTP::Client" => 0,
    "AnyEvent::HTTP" => 0,
    "Fcntl" => 0,
    "File::Basename" => 0,
    "Getopt::Long" => "2.36",
    "JSON::MaybeXS" => 0,
    "List::Util" => 0,
    "List::UtilsBy" => 0,
    "MooX" => 0,
    "MooX::late" => "0.007",
    "URI" => 0,
    "autodie" => 0,
    "perl" => "5.012",
    "strict" => 0,
    "warnings" => 0
  },
  "script_files" => [
    "bin/mdown"
  ],
  "test_requires" => {
    "File::Spec" => 0,
    "IO::Handle" => 0,
    "IPC::Open3" => 0,
    "Test::More" => "0.88"
  }
);


my %fallback_build_requires = (
  "File::Spec" => 0,
  "IO::Handle" => 0,
  "IPC::Open3" => 0,
  "Module::Build" => "0.28",
  "Test::More" => "0.88"
);


unless ( eval { Module::Build->VERSION(0.4004) } ) {
  delete $module_build_args{test_requires};
  $module_build_args{build_requires} = \%fallback_build_requires;
}

my $build = Module::Build->new(%module_build_args);


$build->create_build_script;