# This Makefile.PL for Printer-ESCPOS was generated by
# Dist::Zilla::Plugin::MakeMaker::Awesome 0.38.
# Don't edit it but the dist.ini and plugins used to construct it.

use strict;
use warnings;

use 5.010;
use ExtUtils::MakeMaker;

my %WriteMakefileArgs = (
  "ABSTRACT" => "Interface for all thermal, dot-matrix and other receipt printers that support ESC-POS specification.",
  "AUTHOR" => "Shantanu Bhadoria <shantanu\@cpan.org> L<https://www.shantanubhadoria.com>",
  "CONFIGURE_REQUIRES" => {
    "ExtUtils::MakeMaker" => 0
  },
  "DISTNAME" => "Printer-ESCPOS",
  "LICENSE" => "perl",
  "MIN_PERL_VERSION" => "5.010",
  "NAME" => "Printer::ESCPOS",
  "PREREQ_PM" => {
    "Carp" => 0,
    "Class::Load" => 0,
    "Device::SerialPort" => 0,
    "Device::USB" => 0,
    "File::Temp" => 0,
    "GD::Barcode::QRcode" => 0,
    "IO::File" => 0,
    "IO::Socket" => 0,
    "Moo" => 0,
    "Moo::Role" => 0,
    "Pango" => 0,
    "Scalar::Util::Numeric" => 0,
    "Time::HiRes" => 0,
    "Type::Tiny" => 0,
    "aliased" => 0,
    "constant" => 0,
    "strict" => 0,
    "utf8" => 0,
    "warnings" => 0
  },
  "TEST_REQUIRES" => {
    "ExtUtils::MakeMaker" => 0,
    "File::Spec" => 0,
    "File::Temp" => 0,
    "IO::Handle" => 0,
    "IPC::Open3" => 0,
    "Test::More" => 0,
    "blib" => "1.01"
  },
  "VERSION" => "1.006",
  "test" => {
    "TESTS" => "t/*.t"
  }
);

my %FallbackPrereqs = (
  "Carp" => 0,
  "Class::Load" => 0,
  "Device::SerialPort" => 0,
  "Device::USB" => 0,
  "ExtUtils::MakeMaker" => 0,
  "File::Spec" => 0,
  "File::Temp" => 0,
  "GD::Barcode::QRcode" => 0,
  "IO::File" => 0,
  "IO::Handle" => 0,
  "IO::Socket" => 0,
  "IPC::Open3" => 0,
  "Moo" => 0,
  "Moo::Role" => 0,
  "Pango" => 0,
  "Scalar::Util::Numeric" => 0,
  "Test::More" => 0,
  "Time::HiRes" => 0,
  "Type::Tiny" => 0,
  "aliased" => 0,
  "blib" => "1.01",
  "constant" => 0,
  "strict" => 0,
  "utf8" => 0,
  "warnings" => 0
);

unless ( eval { ExtUtils::MakeMaker->VERSION(6.63_03) } ) {
  delete $WriteMakefileArgs{TEST_REQUIRES};
  delete $WriteMakefileArgs{BUILD_REQUIRES};
  $WriteMakefileArgs{PREREQ_PM} = \%FallbackPrereqs;
}

delete $WriteMakefileArgs{CONFIGURE_REQUIRES}
  unless eval { ExtUtils::MakeMaker->VERSION(6.52) };

WriteMakefile(%WriteMakefileArgs);