name    = Reindeer
author  = Chris Weyl <cweyl@alumni.drew.edu>
license = LGPL_2_1
copyright_holder = Chris Weyl
copyright_year   = 2011

; sigh...  UseAllModules doesn't play well with roles; plus
; ConsistentVersionTest is convinced that the POD version in Reindeer (and not
; Reindeer::Role or Reindeer::Util) is incorrect.
[@Filter]
-bundle = @RSRCHBOY
-remove = Test::UseAllModules
-remove = ConsistentVersionTest
; trips up on too many of the included POD sections
-remove = Test::PodSpelling
-remove = Test::EOL
autoprereqs_skip = ^(funcs|Test(Class|Role).*)$
tweet = 1
Test::MinimumVersion.max_target_perl = 5.10.1

; needed for PW to do its thing here.
;
; authordep Pod::Weaver::Section::Collect::FromOther
; authordep MooseX::AbstractMethod
; authordep MooseX::AttributeShortcuts
; authordep MooseX::NewDefaults
; authordep MooseX::Types::LoadableClass
; authordep MooseX::Types::Common::String
; authordep MooseX::Types::Common::Numeric
; authordep MooseX::Types::Tied::Hash::IxHash


[Prereqs / DevelopRequires]
MooseX::UndefTolerant::Attribute = 0
MooseX::AutoDestruct = 0