name    = XML-Rabbit
author  = Robin Smidsrød <robin@smidsrod.no>
license = Perl_5
copyright_holder = Robin Smidsrød

;Semantic versioning, see http://semver.org/
version = 0.4.1

[NextRelease]
[@Git]

[@Filter]
-bundle = @Basic
-remove = Readme
-remove = MakeMaker

; We need to bail out when we encounter incompatible libxml2 versions
[=inc::MyMakeMaker / MyMakeMaker]

[MetaJSON]
[PkgVersion]
[PodWeaver]

[MetaResources]
repository.url  = git://github.com/robinsmidsrod/XML-Rabbit.git
repository.web  = http://github.com/robinsmidsrod/XML-Rabbit
repository.type = git

[InstallGuide]
[ReadmeFromPod]
[ReadmeMarkdownFromPod]
[CopyFilesFromBuild]
move = README.mkdn

[PodSyntaxTests]
[PodCoverageTests]
[Test::Perl::Critic]
[Test::Kwalitee]
[NoTabsTests]
[EOLTests]

;Need to get my signing stuff setup properly...
;[Signature]

[AutoPrereqs]

[Prereqs / ConfigureRequires]
XML::LibXML = 1.70 ; Required for libxml2 runtime version check

; authordep Pod::Weaver::Section::Support
; authordep Pod::Weaver::Plugin::Encoding
; authordep Pod::Elemental::Transformer::List
; authordep Dist::Zilla::Plugin::MakeMaker::Awesome
; authordep Test::Pod::Coverage
; authordep Pod::Coverage::TrustPod
; authordep Test::Perl::Critic
; authordep Perl::Critic::Policy::Miscellanea::RequireRcsKeywords
; authordep Perl::Critic::Policy::Lax::RequireExplicitPackage::ExceptForPragmata