# This file was automatically generated by Dist::Zilla::Plugin::MakeMaker v6.021.
use strict;
use warnings;

use 5.008000;

use ExtUtils::MakeMaker 6.78;

my %WriteMakefileArgs = (
  "ABSTRACT" => "a sophisticated exporter for custom-built routines",
  "AUTHOR" => "Ricardo Signes <rjbs\@semiotic.systems>",
  "CONFIGURE_REQUIRES" => {
    "ExtUtils::MakeMaker" => "6.78"
  },
  "DISTNAME" => "Sub-Exporter",
  "LICENSE" => "perl",
  "MIN_PERL_VERSION" => "5.008000",
  "NAME" => "Sub::Exporter",
  "PREREQ_PM" => {
    "Carp" => 0,
    "Data::OptList" => "0.100",
    "Params::Util" => "0.14",
    "Sub::Install" => "0.92",
    "strict" => 0,
    "warnings" => 0
  },
  "TEST_REQUIRES" => {
    "Exporter" => 0,
    "ExtUtils::MakeMaker" => 0,
    "File::Spec" => 0,
    "Test::More" => "0.96",
    "base" => 0,
    "lib" => 0,
    "overload" => 0,
    "subs" => 0
  },
  "VERSION" => "0.988",
  "test" => {
    "TESTS" => "t/*.t"
  }
);


my %FallbackPrereqs = (
  "Carp" => 0,
  "Data::OptList" => "0.100",
  "Exporter" => 0,
  "ExtUtils::MakeMaker" => 0,
  "File::Spec" => 0,
  "Params::Util" => "0.14",
  "Sub::Install" => "0.92",
  "Test::More" => "0.96",
  "base" => 0,
  "lib" => 0,
  "overload" => 0,
  "strict" => 0,
  "subs" => 0,
  "warnings" => 0
);


unless ( eval { ExtUtils::MakeMaker->VERSION(6.63_03) } ) {
  delete $WriteMakefileArgs{TEST_REQUIRES};
  delete $WriteMakefileArgs{BUILD_REQUIRES};
  $WriteMakefileArgs{PREREQ_PM} = \%FallbackPrereqs;
}

delete $WriteMakefileArgs{CONFIGURE_REQUIRES}
  unless eval { ExtUtils::MakeMaker->VERSION(6.52) };

WriteMakefile(%WriteMakefileArgs);