BEGIN {
  use strict; use warnings;
  unless(eval q{ use 5.008001; 1}) {
    print "Perl 5.008001 or better required\n";
    exit;
  }
}
# This file was automatically generated by Dist::Zilla::Plugin::Author::Plicease::MakeMaker v2.63.
use strict;
use warnings;
use 5.008001;
use ExtUtils::MakeMaker;

my %WriteMakefileArgs = (
  "ABSTRACT"           => "Basic cross-platform tests for scripts",
  "AUTHOR"             => "Graham Ollis <plicease\@cpan.org>, Adam Kennedy",
  "CONFIGURE_REQUIRES" => {
    "ExtUtils::MakeMaker" => 0
  },
  "DISTNAME"         => "Test-Script",
  "LICENSE"          => "perl",
  "MIN_PERL_VERSION" => "5.008001",
  "NAME"             => "Test::Script",
  "PM"               => {
    "lib/Test/Script.pm" => "\$(INST_LIB)/Test/Script.pm"
  },
  "PREREQ_PM" => {
    "Capture::Tiny"    => 0,
    "File::Spec"       => "0.80",
    "IO::Handle"       => 0,
    "Probe::Perl"      => "0.01",
    "Test2::API"       => "1.302015",
    "Text::ParseWords" => 0
  },
  "TEST_REQUIRES" => {
    "Test2::V0" => "0.000060"
  },
  "VERSION" => "1.29",
  "test"    => {
    "TESTS" => "t/*.t"
  }
);

my %FallbackPrereqs = (
  "Capture::Tiny"    => 0,
  "File::Spec"       => "0.80",
  "IO::Handle"       => 0,
  "Probe::Perl"      => "0.01",
  "Test2::API"       => "1.302015",
  "Test2::V0"        => "0.000060",
  "Text::ParseWords" => 0
);

unless ( eval { ExtUtils::MakeMaker->VERSION(6.63_03) } ) {
  delete $WriteMakefileArgs{TEST_REQUIRES};
  delete $WriteMakefileArgs{BUILD_REQUIRES};
  $WriteMakefileArgs{PREREQ_PM} = \%FallbackPrereqs;
}

delete $WriteMakefileArgs{CONFIGURE_REQUIRES}
  unless eval { ExtUtils::MakeMaker->VERSION(6.52) };

WriteMakefile(%WriteMakefileArgs);