use strict; use warnings;
BEGIN {
  if($^O eq 'MSWin32')
  {
    print "OS Unsupported\n";
    exit;
  }
  unless(eval q{ use 5.010; 1}) {
    print "Perl 5.010 or better required\n";
    exit;
  }
}

# This file was automatically generated by Dist::Zilla::Plugin::ModuleBuild v6.010.
use strict;
use warnings;

use Module::Build 0.28;
use lib qw{inc}; use My::ModuleBuild;

my %module_build_args = (
  "build_requires" => {
    "Module::Build" => "0.28"
  },
  "configure_requires" => {
    "Module::Build" => "0.28",
    "perl" => "5.006"
  },
  "dist_abstract" => "(Deprecated) Parallel SSH client",
  "dist_author" => [
    "Graham Ollis <plicease\@cpan.org>"
  ],
  "dist_name" => "Clustericious-Admin",
  "dist_version" => "1.11",
  "license" => "perl",
  "module_name" => "Clustericious::Admin",
  "recommends" => {
    "EV" => 0
  },
  "recursive_test_files" => 1,
  "requires" => {
    "AE" => 0,
    "AnyEvent::Open3::Simple" => "0.76",
    "Clustericious::Config" => "1.03",
    "EV" => 0,
    "File::chdir" => 0,
    "Path::Class" => "0.26",
    "YAML::XS" => 0,
    "perl" => "5.010"
  },
  "script_files" => [
    "bin/clad"
  ],
  "test_requires" => {
    "Capture::Tiny" => 0,
    "Test2::Plugin::FauxHomeDir" => 0,
    "Test::Exit" => "0.11",
    "Test::More" => "0.94",
    "Test::Script" => 0,
    "Test::Warn" => 0,
    "perl" => "5.010"
  }
);


my %fallback_build_requires = (
  "Capture::Tiny" => 0,
  "Module::Build" => "0.28",
  "Test2::Plugin::FauxHomeDir" => 0,
  "Test::Exit" => "0.11",
  "Test::More" => "0.94",
  "Test::Script" => 0,
  "Test::Warn" => 0,
  "perl" => "5.010"
);


unless ( eval { Module::Build->VERSION(0.4004) } ) {
  delete $module_build_args{test_requires};
  $module_build_args{build_requires} = \%fallback_build_requires;
}

my $build = My::ModuleBuild->new(%module_build_args);


$build->create_build_script;