language: perl
sudo: false

compiler:
  - clang
  - gcc

perl:
  - "5.30"
  - "5.28"
  - "5.26"
  - "5.24"
  - "5.22"

install:
  # Deal with dependencies
  - cpanm --installdeps --verbose .
  - cpanm -n Devel::Cover
  - cpanm -n Devel::Cover::Report::Coveralls
script:
  - perl Makefile.PL --profiling --sassc
  - make -j5
  - HARNESS_PERL_SWITCHES=-MDevel::Cover PSASS_FORCE_PLUGIN_CHECKS=1 make test
  - make install
  - psass --version
  - psass --list-plugins
  - sassc --version
after_success:
  - find -name *.gcda -type f -exec gcov-4.8 -abc -o `basename {}` {} \;
  - cover -gcov -report coveralls -ignore_re "^/usr" -ignore_re "^plugins" -ignore_re "^libsass"