# This file was automatically generated by Dist::Zilla::Plugin::ModuleBuild v5.031.
use strict;
use warnings;

use Module::Build 0.28;


my %module_build_args = (
  "build_requires" => {
    "Module::Build" => "0.28"
  },
  "configure_requires" => {
    "ExtUtils::MakeMaker" => 0,
    "Module::Build" => "0.28",
    "perl" => "5.006"
  },
  "dist_abstract" => "Get a versioned list of currently loaded modules",
  "dist_author" => [
    "Olaf Alders <olaf\@wundercounter.com>"
  ],
  "dist_name" => "Module-Version-Loaded",
  "dist_version" => "0.000003",
  "license" => "artistic_2",
  "module_name" => "Module::Version::Loaded",
  "recommends" => {},
  "recursive_test_files" => 1,
  "requires" => {
    "Data::Difflet" => 0,
    "Module::Version" => "0.12",
    "Storable" => 0,
    "Sub::Exporter" => 0,
    "perl" => "5.006",
    "strict" => 0,
    "warnings" => 0
  },
  "script_files" => [],
  "test_requires" => {
    "Data::Printer" => 0,
    "File::Temp" => 0,
    "Path::Tiny" => 0,
    "Test::More" => 0,
    "perl" => "5.006"
  }
);


my %fallback_build_requires = (
  "Data::Printer" => 0,
  "File::Temp" => 0,
  "Module::Build" => "0.28",
  "Path::Tiny" => 0,
  "Test::More" => 0,
  "perl" => "5.006"
);


unless ( eval { Module::Build->VERSION(0.4004) } ) {
  delete $module_build_args{test_requires};
  $module_build_args{build_requires} = \%fallback_build_requires;
}

my $build = Module::Build->new(%module_build_args);

$build->create_build_script;