# This file was automatically generated by Dist::Zilla::Plugin::ModuleBuild v6.012.
use strict;
use warnings;

use Module::Build 0.28;


my %module_build_args = (
  "build_requires" => {
    "Module::Build" => "0.28"
  },
  "configure_requires" => {
    "Module::Build" => "0.28"
  },
  "dist_abstract" => "Wrap a REST API around a Catmandu::Bag",
  "dist_author" => [
    "Nicolas Steenlant <nicolas.steenlant\@ugent.be>"
  ],
  "dist_name" => "Plack-App-Catmandu-Bag",
  "dist_version" => "0.0102",
  "license" => "perl",
  "module_name" => "Plack::App::Catmandu::Bag",
  "recursive_test_files" => 1,
  "requires" => {
    "Catmandu" => "1.0506",
    "JSON" => 0,
    "Plack" => "1.0042",
    "Router::Simple" => "0.17",
    "namespace::clean" => 0,
    "perl" => "v5.10.1"
  },
  "test_requires" => {
    "Test::More" => "0.96"
  }
);


my %fallback_build_requires = (
  "Module::Build" => "0.28",
  "Test::More" => "0.96"
);


unless ( eval { Module::Build->VERSION(0.4004) } ) {
  delete $module_build_args{test_requires};
  $module_build_args{build_requires} = \%fallback_build_requires;
}

my $build = Module::Build->new(%module_build_args);


$build->create_build_script;