# This file was automatically generated by Dist::Zilla::Plugin::ModuleBuild v6.012.
use strict;
use warnings;

use Module::Build 0.28;


my %module_build_args = (
  "build_requires" => {
    "Module::Build" => "0.28"
  },
  "configure_requires" => {
    "Module::Build" => "0.28"
  },
  "dist_abstract" => "A searchable store backed by MongoDB",
  "dist_author" => [
    "Nicolas Steenlant, C<< <nicolas.steenlant at ugent.be> >>"
  ],
  "dist_name" => "Catmandu-Store-MongoDB",
  "dist_version" => "0.0806",
  "license" => "perl",
  "module_name" => "Catmandu::Store::MongoDB",
  "recursive_test_files" => 1,
  "requires" => {
    "CQL::Parser" => "1.12",
    "Catmandu" => "1.04",
    "Cpanel::JSON::XS" => "3.0213",
    "MongoDB" => "v1.6.1",
    "Moo" => "1.006000",
    "namespace::clean" => "0.24",
    "perl" => "v5.10.1"
  },
  "test_requires" => {
    "Software::License" => "0.103010",
    "Test::Exception" => "0.32",
    "Test::More" => "1.001003",
    "Test::Pod" => 0,
    "Test::Warn" => 0
  }
);


my %fallback_build_requires = (
  "Module::Build" => "0.28",
  "Software::License" => "0.103010",
  "Test::Exception" => "0.32",
  "Test::More" => "1.001003",
  "Test::Pod" => 0,
  "Test::Warn" => 0
);


unless ( eval { Module::Build->VERSION(0.4004) } ) {
  delete $module_build_args{test_requires};
  $module_build_args{build_requires} = \%fallback_build_requires;
}

my $build = Module::Build->new(%module_build_args);


$build->create_build_script;