# =========================================================================
# THIS FILE IS AUTOMATICALLY GENERATED BY MINILLA.
# DO NOT EDIT DIRECTLY.
# =========================================================================

use 5.008_001;
use strict;

use ExtUtils::MakeMaker;


my %WriteMakefileArgs = (
    NAME     => 'Mojolicious::Plugin::Materialize',
    DISTNAME => 'Mojolicious-Plugin-Materialize',
    VERSION  => '0.9770',
    EXE_FILES => [glob('script/*'), glob('bin/*')],
    CONFIGURE_REQUIRES => {
  "ExtUtils::MakeMaker" => 0
}
,
    BUILD_REQUIRES     => {}
,
    TEST_REQUIRES      => {
  "Mojolicious" => 0,
  "Test::Mojo" => 0,
  "Test::More" => "0.98"
}
,
    PREREQ_PM          => {
  "Mojo::Base" => 0,
  "Mojolicious::Plugin::AssetPack" => 0,
  "Mojolicious::Plugin::AssetPack::Backcompat" => 0,
  "perl" => "5.010001"
}
,
);

my $full_prereqs = {
  "ExtUtils::MakeMaker" => 0,
  "Mojo::Base" => 0,
  "Mojolicious" => 0,
  "Mojolicious::Plugin::AssetPack" => 0,
  "Mojolicious::Plugin::AssetPack::Backcompat" => 0,
  "Test::Mojo" => 0,
  "Test::More" => "0.98",
  "perl" => "5.010001"
}
;

unless (eval { ExtUtils::MakeMaker->VERSION(6.63_03) }) {
    delete $WriteMakefileArgs{TEST_REQUIRES};
    delete $WriteMakefileArgs{BUILD_REQUIRES};
    $WriteMakefileArgs{PREREQ_PM} = $full_prereqs;
}

unless (eval { ExtUtils::MakeMaker->VERSION(6.52) }) {
    delete $WriteMakefileArgs{CONFIGURE_REQUIRES};
}

unless (eval { ExtUtils::MakeMaker->VERSION(6.57_01) }) {
    use File::Copy;
    copy('META.yml', 'MYMETA.yml')   or warn "META.yml: $!";
    copy('META.json', 'MYMETA.json') or warn "META.json: $!";
}

WriteMakefile(%WriteMakefileArgs);