# This file was automatically generated by Dist::Zilla::Plugin::ModuleBuild v6.010.
use strict;
use warnings;

use Module::Build 0.28;
use lib qw{inc}; use Module::Build::Parse::Yapp;

my %module_build_args = (
  "build_requires" => {
    "Module::Build" => "0.28",
    "Module::Build::Parse::Yapp" => 0
  },
  "configure_requires" => {
    "Module::Build" => "0.28",
    "Module::Build::Parse::Yapp" => 0
  },
  "dist_abstract" => "OPTiMaDe filter language parser/composer",
  "dist_author" => [
    "Andrius Merkys <merkys\@cpan.org>"
  ],
  "dist_name" => "OPTiMaDe-Filter",
  "dist_version" => "0.7.2",
  "license" => "lgpl",
  "module_name" => "OPTiMaDe::Filter",
  "recursive_test_files" => 1,
  "requires" => {
    "Parse::Yapp" => 0,
    "Scalar::Util" => 0
  },
  "test_requires" => {
    "Data::Compare" => 0,
    "Data::Dumper" => 0,
    "File::Spec" => 0,
    "Scalar::Util" => 0,
    "Test::More" => 0
  }
);


my %fallback_build_requires = (
  "Data::Compare" => 0,
  "Data::Dumper" => 0,
  "File::Spec" => 0,
  "Module::Build" => "0.28",
  "Module::Build::Parse::Yapp" => 0,
  "Scalar::Util" => 0,
  "Test::More" => 0
);


unless ( eval { Module::Build->VERSION(0.4004) } ) {
  delete $module_build_args{test_requires};
  $module_build_args{build_requires} = \%fallback_build_requires;
}

my $build = Module::Build::Parse::Yapp->new(%module_build_args);
$build->add_build_element($_) for qw(yp);

$build->create_build_script;