# This file was automatically generated by Dist::Zilla::Plugin::ModuleBuild v6.012.
use strict;
use warnings;

use Module::Build 0.28;
use lib qw{inc}; use GPD::Build;

my %module_build_args = (
  "build_requires" => {
    "ExtUtils::ParseXS" => "2.30",
    "ExtUtils::Typemaps::Default" => "1.05",
    "Module::Build" => "0.28"
  },
  "configure_requires" => {
    "Alien::ProtoBuf" => "0.08",
    "Alien::uPB::Core" => "0.16",
    "Module::Build" => "0.28",
    "Module::Build::WithXSpp" => "0.14"
  },
  "dist_abstract" => "fast and complete protocol buffer implementation",
  "dist_author" => [
    "Mattia Barbon <mattia\@barbon.org>"
  ],
  "dist_name" => "Google-ProtocolBuffers-Dynamic",
  "dist_version" => "0.32",
  "license" => "perl",
  "module_name" => "Google::ProtocolBuffers::Dynamic",
  "recursive_test_files" => 1,
  "requires" => {
    "autodie" => 0,
    "perl" => "5.008"
  },
  "test_requires" => {
    "Test::Exception" => 0,
    "Test::Warn" => 0
  }
);


my %fallback_build_requires = (
  "ExtUtils::ParseXS" => "2.30",
  "ExtUtils::Typemaps::Default" => "1.05",
  "Module::Build" => "0.28",
  "Test::Exception" => 0,
  "Test::Warn" => 0
);


unless ( eval { Module::Build->VERSION(0.4004) } ) {
  delete $module_build_args{test_requires};
  $module_build_args{build_requires} = \%fallback_build_requires;
}

my $build = GPD::Build->new(%module_build_args);


$build->create_build_script;