; vim: syntax=dosini
name    = Dist-Zilla-PluginBundle-Author-KENTNL

author  = Kent Fredric <kentnl@cpan.org>
license = Perl_5
copyright_holder = Kent Fredric <kentfredric@gmail.com>

main_module = lib/Dist/Zilla/PluginBundle/Author/KENTNL.pm
; build me with dzil -Ilib build  :)
; that way we build using ourself!
[Bootstrap::lib]
try_built = 1

[Prereqs]
Dist::Zilla = 5.011

[Prereqs / config_reqs]
-phase = configure
-relationship = requires
File::ShareDir::Install = 0.10 ; dotfiles bug

[Prereqs/softdeps]
-phase = runtime
-type = recommends
Dist::Zilla::Plugin::Bootstrap::lib = 0.04000002
Dist::Zilla::Plugin::PerlTidy = 0.14
Dist::Zilla::Util::EmulatePhase = 0.01025803
Dist::Zilla::Plugin::Author::KENTNL::TravisCI = 0.001001
IO::Socket::SSL         = 1.962
LWP::Protocol::https    = 6.04 ; This is required for a working ::Twitter plugin.
Moose                   = 2.1201
MooseX::Has::Sugar      = 1.000000
MooseX::Types           = 0.41
Net::SSLeay             = 1.57
Perl::PrereqScanner     = 1.019
Pod::Coverage::TrustPod = 0.100003
Pod::Elemental::PerlMunger = 0.200001 ; Replace with blank
Test::CPAN::Meta        = 0.23
Test::Pod               = 1.48
Test::Pod::Coverage     = 1.08
Test::EOL               = 1.5
namespace::autoclean    = 0.15
Test::Perl::Critic      = 1.02


[ModuleShareDirs]
Dist::Zilla::MintingProfile::Author::KENTNL = share/profiles

[Prereqs / criticspreqs]
-phase = runtime
-type = recommends
Perl::Critic::Itch = 0
Perl::Critic::Policy::Variables::ProhibitUnusedVarsStricter = 0
Perl::Critic::Pulp = 0
Perl::Critic::More = 0
Perl::Critic::Tics = 0
Perl::Critic::StricterSubs = 0
Perl::Critic::Deprecated = 0
;Perl::Critic::Moose = 0.999_002
Perl::Critic::Lax = 0
Perl::Critic::Compatibility = 0
Perl::Critic::Swift = 0
Perl::Critic::Bangs = 0

[Prereqs / conditionalpreqs]
-phase = runtime
-type = recommends
Dist::Zilla::Plugin::MakeMaker       = 0
Dist::Zilla::Plugin::ModuleBuild     = 0
Dist::Zilla::Plugin::ModuleBuildTiny = 0
Dist::Zilla::Plugin::Prereqs::MatchInstalled = 0
Dist::Zilla::Plugin::Prereqs::Recommend::MatchInstalled = 0
Dist::Zilla::Plugin::Git::NextVersion::Sanitized = 0

CPAN::Meta                           = 0
CPAN::Meta::Prereqs::Diff            = 0
CPAN::Changes::Group::Dependencies::Stats   = 0.002002
CPAN::Changes::Dependencies::Details = 0.001000

JSON::MaybeXS                        = 0
Cpanel::JSON::XS                     = 0

[Prereqs / testreqs]
-phase = test
-type  = requires
Dist::Zilla::Plugin::Prereqs::MatchInstalled     = 0
Dist::Zilla::Plugin::ModuleBuild                 = 0
Dist::Zilla::Plugin::Git::NextVersion::Sanitized = 0
Module::Build                                    = 0
Dist::Zilla::Plugin::Author::KENTNL::TravisCI    = 0

[@Author::KENTNL]
twitter_extra_hash_tags = #distzilla
normal_form       = numify
mantissa          = 6
bundledeps_phase  = runtime
toolkit           = eumm
toolkit_hardness  = soft
bump_versions     = 1
src_readme        = mkdn
Author::KENTNL::TravisCI.skip_perls = 5.8

;[Prereqs::SyncVersions]
[CheckPrereqsIndexed]
skips = Dist::Zilla::PluginBundle::Author::KENTNL