Changes for version 2.104 - 2008-10-08

  • Added the oodoc_version executable script Replaced "use" by "require" for Tk and Text::Wrapper in examples, in order to avoid some non essential installation dependencies. Text.pm: bug fix in extendText() (#39174) Perl >= 5.8 required in every PM file Licensing: now GNU-LGPL 2.1 only

Documentation

Introduction to the Open OpenDocument Connector

Modules

The Perl Open OpenDocument Connector
Top level component for content and layout processing
I/O operations with OpenDocument files
Image manipulation methods
Access to document file descriptor
Access to document metadata
Document styles and layout processing
The text processing submodule of OpenOffice::OODoc
Low-level navigation in the documents

Provides

in OODoc/Image.pm
in OODoc/Styles.pm
in OODoc/Text.pm
in OODoc/XPath.pm