use if ! ( grep { $_ eq '.' } @INC ), qw[lib .];
use lib 'inc';
use Devel::AssertOS qw[Linux];

# This file was automatically generated by Dist::Zilla::Plugin::ModuleBuild v6.011.
use strict;
use warnings;

use Module::Build 0.28;


my %module_build_args = (
  "build_requires" => {
    "Module::Build" => "0.28"
  },
  "configure_requires" => {
    "ExtUtils::MakeMaker" => 0,
    "Module::Build" => "0.28"
  },
  "dist_abstract" => "Raspberry Pi SD-flashing script with safety checks to avoid erasing the wrong device",
  "dist_author" => [
    "Ian Kluft <cpan-dev\@iankluft.com>"
  ],
  "dist_name" => "PiFlash",
  "dist_version" => "0.4.3",
  "license" => "apache",
  "module_name" => "PiFlash",
  "recursive_test_files" => 1,
  "requires" => {
    "Carp" => 0,
    "File::Basename" => 0,
    "File::LibMagic" => 0,
    "File::Path" => 0,
    "File::Slurp" => 0,
    "Getopt::Long" => 0,
    "IO::Handle" => 0,
    "IO::Poll" => 0,
    "Module::Pluggable" => 0,
    "POSIX" => 0,
    "Try::Tiny" => 0,
    "YAML::XS" => 0,
    "autodie" => 0,
    "parent" => 0,
    "perl" => "v5.14.0",
    "strict" => 0,
    "warnings" => 0
  },
  "script_files" => [
    "bin/piflash"
  ],
  "test_requires" => {
    "Data::Dumper" => 0,
    "Test::More" => 0
  }
);


my %fallback_build_requires = (
  "Data::Dumper" => 0,
  "Module::Build" => "0.28",
  "Test::More" => 0
);


unless ( eval { Module::Build->VERSION(0.4004) } ) {
  delete $module_build_args{test_requires};
  $module_build_args{build_requires} = \%fallback_build_requires;
}

my $build = Module::Build->new(%module_build_args);


$build->create_build_script;