# This file was automatically generated by Dist::Zilla::Plugin::MakeMaker v5.009.
use strict;
use warnings;



use ExtUtils::MakeMaker 6.30;



my %WriteMakefileArgs = (
  "ABSTRACT" => "A tools provide few useful MediaWiki operation",
  "AUTHOR" => "Natal Ng\x{e9}tal",
  "BUILD_REQUIRES" => {
    "Module::Build" => "0.3601"
  },
  "CONFIGURE_REQUIRES" => {
    "ExtUtils::MakeMaker" => "6.30",
    "Module::Build" => "0.3601"
  },
  "DISTNAME" => "MediaWikiUtils",
  "EXE_FILES" => [],
  "LICENSE" => "perl",
  "NAME" => "MediaWikiUtils",
  "PREREQ_PM" => {
    "Carp" => 0,
    "LWP::UserAgent" => 0,
    "MediaWiki::API" => 0,
    "Moo" => 0,
    "MooX::Cmd" => 0,
    "MooX::Options" => 0,
    "Text::Unaccent::PurePerl" => 0,
    "Types::Standard" => 0,
    "pQuery" => 0,
    "strict" => 0,
    "warnings" => 0
  },
  "TEST_REQUIRES" => {
    "Test::More" => 0
  },
  "VERSION" => "0.141410",
  "test" => {
    "TESTS" => "t/*.t"
  }
);


my %FallbackPrereqs = (
  "Carp" => 0,
  "LWP::UserAgent" => 0,
  "MediaWiki::API" => 0,
  "Module::Build" => "0.3601",
  "Moo" => 0,
  "MooX::Cmd" => 0,
  "MooX::Options" => 0,
  "Test::More" => 0,
  "Text::Unaccent::PurePerl" => 0,
  "Types::Standard" => 0,
  "pQuery" => 0,
  "strict" => 0,
  "warnings" => 0
);


unless ( eval { ExtUtils::MakeMaker->VERSION(6.63_03) } ) {
  delete $WriteMakefileArgs{TEST_REQUIRES};
  delete $WriteMakefileArgs{BUILD_REQUIRES};
  $WriteMakefileArgs{PREREQ_PM} = \%FallbackPrereqs;
}

delete $WriteMakefileArgs{CONFIGURE_REQUIRES}
  unless eval { ExtUtils::MakeMaker->VERSION(6.52) };

WriteMakefile(%WriteMakefileArgs);