# This file was automatically generated by Dist::Zilla::Plugin::MakeMaker v5.019.
use strict;
use warnings;



use ExtUtils::MakeMaker 6.30;



my %WriteMakefileArgs = (
  "ABSTRACT" => "Use a PSGI app as a Catalyst action",
  "AUTHOR" => "Arthur Axel \"fREW\" Schmidt <frioux+cpan\@gmail.com>",
  "CONFIGURE_REQUIRES" => {
    "ExtUtils::MakeMaker" => "6.30"
  },
  "DISTNAME" => "Catalyst-Action-FromPSGI",
  "EXE_FILES" => [],
  "LICENSE" => "perl",
  "NAME" => "Catalyst::Action::FromPSGI",
  "PREREQ_PM" => {
    "Catalyst::Runtime" => "5.90049004",
    "Plack" => "0.992"
  },
  "TEST_REQUIRES" => {
    "HTTP::Request::Common" => 0,
    "Test::More" => "0.88",
    "Web::Simple" => "0.016"
  },
  "VERSION" => "0.001006",
  "test" => {
    "TESTS" => "t/*.t"
  }
);


my %FallbackPrereqs = (
  "Catalyst::Runtime" => "5.90049004",
  "HTTP::Request::Common" => 0,
  "Plack" => "0.992",
  "Test::More" => "0.88",
  "Web::Simple" => "0.016"
);


unless ( eval { ExtUtils::MakeMaker->VERSION(6.63_03) } ) {
  delete $WriteMakefileArgs{TEST_REQUIRES};
  delete $WriteMakefileArgs{BUILD_REQUIRES};
  $WriteMakefileArgs{PREREQ_PM} = \%FallbackPrereqs;
}

delete $WriteMakefileArgs{CONFIGURE_REQUIRES}
  unless eval { ExtUtils::MakeMaker->VERSION(6.52) };

WriteMakefile(%WriteMakefileArgs);