# This file was automatically generated by Dist::Zilla::Plugin::ModuleBuild v6.012.
use strict;
use warnings;

use Module::Build 0.28;


my %module_build_args = (
  "build_requires" => {
    "Module::Build" => "0.28"
  },
  "configure_requires" => {
    "Module::Build" => "0.28"
  },
  "dist_abstract" => "Jojo::Base and Jojo::Role for pure Perl environments",
  "dist_author" => [
    "Adriano Ferreira <ferreira\@cpan.org>"
  ],
  "dist_name" => "Jojo-Compat",
  "dist_version" => "0.2.0",
  "license" => "perl",
  "module_name" => "Jojo::Compat",
  "recursive_test_files" => 1,
  "requires" => {
    "Carp" => 0,
    "Importer::Zim" => 0,
    "Module::Spec::V2" => 0,
    "Mojo::Base" => 0,
    "Mojo::Util" => 0,
    "Mojolicious" => "7.55",
    "Role::Tiny" => "2.000006",
    "constant" => 0,
    "experimental" => 0,
    "feature" => 0,
    "perl" => "5.018",
    "strict" => 0,
    "utf8" => 0,
    "warnings" => 0
  },
  "test_requires" => {
    "ExtUtils::MakeMaker" => 0,
    "File::Spec" => 0,
    "Test::More" => "0.96"
  }
);


my %fallback_build_requires = (
  "ExtUtils::MakeMaker" => 0,
  "File::Spec" => 0,
  "Module::Build" => "0.28",
  "Test::More" => "0.96"
);


unless ( eval { Module::Build->VERSION(0.4004) } ) {
  delete $module_build_args{test_requires};
  $module_build_args{build_requires} = \%fallback_build_requires;
}

my $build = Module::Build->new(%module_build_args);


$build->create_build_script;