# This Makefile.PL for Pod-Tests was generated by
# Dist::Zilla::Plugin::MakeMaker::Awesome 0.47.
# Don't edit it but the dist.ini and plugins used to construct it.

use strict;
use warnings;

use 5.006;
use ExtUtils::MakeMaker;

my %WriteMakefileArgs = (
  "ABSTRACT" => "(DEPRECATED) Extracts embedded tests and code examples from POD",
  "AUTHOR" => "Michael G Schwern <schwern\@pobox.com>",
  "CONFIGURE_REQUIRES" => {
    "ExtUtils::MakeMaker" => 0
  },
  "DISTNAME" => "Pod-Tests",
  "EXE_FILES" => [
    "script/pod2test"
  ],
  "LICENSE" => "perl",
  "MIN_PERL_VERSION" => "5.006",
  "NAME" => "Pod::Tests",
  "PREREQ_PM" => {
    "File::Spec" => 0,
    "Symbol" => 0,
    "Test::Harness" => "1.22",
    "strict" => 0
  },
  "TEST_REQUIRES" => {
    "ExtUtils::MakeMaker" => 0,
    "File::Spec" => 0,
    "POSIX" => 0,
    "Test::More" => 0,
    "warnings" => 0
  },
  "VERSION" => "1.20",
  "test" => {
    "TESTS" => "t/*.t"
  }
);

my %FallbackPrereqs = (
  "ExtUtils::MakeMaker" => 0,
  "File::Spec" => 0,
  "POSIX" => 0,
  "Symbol" => 0,
  "Test::Harness" => "1.22",
  "Test::More" => 0,
  "strict" => 0,
  "warnings" => 0
);

unless ( eval { ExtUtils::MakeMaker->VERSION('6.63_03') } ) {
  delete $WriteMakefileArgs{TEST_REQUIRES};
  delete $WriteMakefileArgs{BUILD_REQUIRES};
  $WriteMakefileArgs{PREREQ_PM} = \%FallbackPrereqs;
}

delete $WriteMakefileArgs{CONFIGURE_REQUIRES}
  unless eval { ExtUtils::MakeMaker->VERSION(6.52) };

WriteMakefile(%WriteMakefileArgs);

# Generate tests via pod2test to be run later
print "Running pod2test...\n";
system(qq{$^X "-Ilib" script/pod2test t/02_tests.t t/03_pod2test.t});
system(qq{$^X "-Ilib" script/pod2test t/foo t/i_should_not_be_written.t});