This is the Perl distribution Dist-Zilla-Plugin-GitHub.

Installing Dist-Zilla-Plugin-GitHub is straightforward.

## Installation with cpanm

If you have cpanm, you only need one line:

    % cpanm Dist::Zilla::Plugin::GitHub

If it does not have permission to install modules to the current perl, cpanm
will automatically set up and install to a local::lib in your home directory.
See the local::lib documentation (https://metacpan.org/pod/local::lib) for
details on enabling it in your environment.

## Installing with the CPAN shell

Alternatively, if your CPAN shell is set up, you should just be able to do:

    % cpan Dist::Zilla::Plugin::GitHub

## Manual installation

As a last resort, you can manually install it. Download the tarball, untar it,
install configure prerequisites (see below), then build it:

    % perl Build.PL
    % ./Build && ./Build test

Then install it:

    % ./Build install

Or the more portable variation:

    % perl Build.PL
    % perl Build
    % perl Build test
    % perl Build install

If your perl is system-managed, you can create a local::lib in your home
directory to install modules to. For details, see the local::lib documentation:
https://metacpan.org/pod/local::lib

The prerequisites of this distribution will also have to be installed manually. The
prerequisites are listed in one of the files: `MYMETA.yml` or `MYMETA.json` generated
by running the manual build process described above.

## Configure Prerequisites

This distribution requires other modules to be installed before this
distribution's installer can be run.  They can be found under the
"configure_requires" key of META.yml or the
"{prereqs}{configure}{requires}" key of META.json.

## Other Prerequisites

This distribution may require additional modules to be installed after running
Build.PL or Makefile.PL.
Look for prerequisites in the following phases:

* to run ./Build or make, PHASE = build
* to use the module code itself, PHASE = runtime
* to run tests, PHASE = test

They can all be found in the "PHASE_requires" key of MYMETA.yml or the
"{prereqs}{PHASE}{requires}" key of MYMETA.json.

## Documentation

Dist-Zilla-Plugin-GitHub documentation is available as POD.
You can run `perldoc` from a shell to read the documentation:

    % perldoc Dist::Zilla::Plugin::GitHub

For more information on installing Perl modules via CPAN, please see:
https://www.cpan.org/modules/INSTALL.html