# This file was automatically generated by Dist::Zilla::Plugin::ModuleBuild v6.017.
use strict;
use warnings;

use Module::Build 0.28;


my %module_build_args = (
  "build_requires" => {
    "Module::Build" => "0.28"
  },
  "configure_requires" => {
    "Module::Build" => "0.28"
  },
  "dist_abstract" => "Check and report status of various services needed by your app",
  "dist_author" => [
    "Thomas Klausner <domm\@plix.at>"
  ],
  "dist_name" => "Plack-App-ServiceStatus",
  "dist_version" => "0.904",
  "license" => "perl",
  "module_name" => "Plack::App::ServiceStatus",
  "recursive_test_files" => 1,
  "requires" => {
    "Class::Accessor::Fast" => 0,
    "JSON::MaybeXS" => 0,
    "Log::Any" => 0,
    "Module::Runtime" => 0,
    "Plack::Response" => 0,
    "Try::Tiny" => 0,
    "base" => 0,
    "perl" => "5.018"
  },
  "test_requires" => {
    "File::Spec" => 0,
    "File::Temp" => 0,
    "IO::Handle" => 0,
    "IPC::Open3" => 0,
    "Test::MockModule" => 0,
    "Test::MockObject" => 0,
    "Test::More" => 0
  }
);


my %fallback_build_requires = (
  "File::Spec" => 0,
  "File::Temp" => 0,
  "IO::Handle" => 0,
  "IPC::Open3" => 0,
  "Module::Build" => "0.28",
  "Test::MockModule" => 0,
  "Test::MockObject" => 0,
  "Test::More" => 0
);


unless ( eval { Module::Build->VERSION(0.4004) } ) {
  delete $module_build_args{test_requires};
  $module_build_args{build_requires} = \%fallback_build_requires;
}

my $build = Module::Build->new(%module_build_args);


$build->create_build_script;