---
abstract: 'Detects the minimum version of Perl required for your dist'
author:
  - 'Apocalypse <APOCAL@cpan.org>'
build_requires:
  File::Spec: '0'
  File::Temp: '0'
  IO::Handle: '0'
  IPC::Open3: '0'
  Test::More: '0.88'
  perl: '5.006'
configure_requires:
  ExtUtils::MakeMaker: '0'
  Module::Build::Tiny: '0.039'
  perl: '5.006'
dynamic_config: '0'
generated_by: 'Dist::Zilla version 5.023, CPAN::Meta::Converter version 2.142690'
license: perl
meta-spec:
  url: http://module-build.sourceforge.net/META-spec-v1.4.html
  version: '1.4'
name: Dist-Zilla-Plugin-MinimumPerl
no_index:
  directory:
    - examples
provides:
  Dist::Zilla::Plugin::MinimumPerl:
    file: lib/Dist/Zilla/Plugin/MinimumPerl.pm
    version: '1.006'
requires:
  Dist::Zilla::Role::FileFinderUser: '4.200006'
  Dist::Zilla::Role::PrereqSource: '5.006'
  Moose: '1.03'
  Moose::Util::TypeConstraints: '1.01'
  MooseX::Types::Perl: '0.101340'
  Perl::MinimumVersion: '1.26'
  perl: '5.006'
  strict: '0'
  warnings: '0'
resources:
  bugtracker: http://rt.cpan.org/Public/Dist/Display.html?Name=Dist-Zilla-Plugin-MinimumPerl
  homepage: http://search.cpan.org/dist/Dist-Zilla-Plugin-MinimumPerl/
  license: http://dev.perl.org/licenses/
  repository: git://github.com/apocalypse/perl-dist-zilla-plugin-minimumperl.git
version: '1.006'
x_BuiltWith:
  modules:
    Dist::Zilla::Role::FileFinderUser: '5.023'
    Dist::Zilla::Role::PrereqSource: '5.023'
    ExtUtils::MakeMaker: '7.00'
    File::Spec: '3.47'
    File::Temp: '0.2304'
    IO::Handle: '1.34'
    IPC::Open3: '1.13'
    Module::Build::Tiny: '0.039'
    Moose: '2.1213'
    Moose::Util::TypeConstraints: '2.1213'
    MooseX::Types::Perl: '0.101343'
    Perl::MinimumVersion: '1.38'
    Test::More: '1.001008'
    strict: '1.07'
    version: '0.9909'
    warnings: '1.18'
  perl:
    original: v5.18.2
    qv: 1
    version:
      - 5
      - 18
      - 2
  platform: linux
  uname: 'Linux 3.13.0-35-generic x86_64'
x_Dist_Zilla:
  perl:
    version: '5.018002'
  plugins:
    -
      class: Dist::Zilla::Plugin::Git::NextVersion
      config:
        Dist::Zilla::Plugin::Git::NextVersion:
          first_version: '0.001'
          version_by_branch: '0'
          version_regexp: (?^:^release-(.+)$)
        Dist::Zilla::Role::Git::Repo:
          repo_root: .
      name: '@Apocalyptic/Git::NextVersion'
      version: '2.025'
    -
      class: Dist::Zilla::Plugin::Git::GatherDir
      config:
        Dist::Zilla::Plugin::GatherDir:
          exclude_filename:
            - README.pod
          exclude_match: []
          follow_symlinks: '0'
          include_dotfiles: '0'
          prefix: ''
          prune_directory: []
          root: .
        Dist::Zilla::Plugin::Git::GatherDir:
          include_untracked: '0'
        Dist::Zilla::Role::Git::Repo:
          repo_root: .
      name: '@Apocalyptic/Git::GatherDir'
      version: '2.025'
    -
      class: Dist::Zilla::Plugin::PruneCruft
      name: '@Apocalyptic/PruneCruft'
      version: '5.023'
    -
      class: Dist::Zilla::Plugin::AutoPrereqs
      name: '@Apocalyptic/AutoPrereqs'
      version: '5.023'
    -
      class: Dist::Zilla::Plugin::GenerateFile
      name: '@Apocalyptic/MANIFEST.SKIP'
      version: '5.023'
    -
      class: Dist::Zilla::Plugin::ManifestSkip
      name: '@Apocalyptic/ManifestSkip'
      version: '5.023'
    -
      class: Dist::Zilla::Plugin::Test::Compile
      config:
        Dist::Zilla::Plugin::Test::Compile:
          bail_out_on_fail: '0'
          fail_on_warning: author
          fake_home: '1'
          filename: t/00-compile.t
          module_finder:
            - ':InstallModules'
          needs_display: '0'
          phase: test
          script_finder:
            - ':ExecFiles'
          skips: []
      name: '@Apocalyptic/Test::Compile'
      version: '2.051'
    -
      class: Dist::Zilla::Plugin::ApocalypseTests
      name: '@Apocalyptic/ApocalypseTests'
      version: '1.002'
    -
      class: Dist::Zilla::Plugin::ReportVersions::Tiny
      name: '@Apocalyptic/ReportVersions::Tiny'
      version: '1.10'
    -
      class: Dist::Zilla::Plugin::Prepender
      name: '@Apocalyptic/Prepender'
      version: '1.112280'
    -
      class: Dist::Zilla::Plugin::Authority
      name: '@Apocalyptic/Authority'
      version: '1.009'
    -
      class: Dist::Zilla::Plugin::Git::Describe
      name: '@Apocalyptic/Git::Describe'
      version: '0.003'
    -
      class: Dist::Zilla::Plugin::PkgVersion
      name: '@Apocalyptic/PkgVersion'
      version: '5.023'
    -
      class: Dist::Zilla::Plugin::PodWeaver
      config:
        Dist::Zilla::Plugin::PodWeaver:
          config_plugins:
            - '@Apocalyptic'
          finder:
            - ':InstallModules'
            - ':ExecFiles'
          plugins:
            -
              class: Pod::Weaver::Plugin::EnsurePod5
              name: '@CorePrep/EnsurePod5'
              version: '4.006'
            -
              class: Pod::Weaver::Plugin::H1Nester
              name: '@CorePrep/H1Nester'
              version: '4.006'
            -
              class: Pod::Weaver::Plugin::SingleEncoding
              name: '@Apocalyptic/SingleEncoding'
              version: '4.006'
            -
              class: Pod::Weaver::Section::Region
              name: '@Apocalyptic/PodCoverage'
              version: '4.006'
            -
              class: Pod::Weaver::Plugin::StopWords
              name: '@Apocalyptic/StopWords'
              version: '1.009'
            -
              class: Pod::Weaver::Section::Name
              name: '@Apocalyptic/Name'
              version: '4.006'
            -
              class: Pod::Weaver::Section::Version
              name: '@Apocalyptic/Version'
              version: '4.006'
            -
              class: Pod::Weaver::Section::Generic
              name: '@Apocalyptic/Synopsis'
              version: '4.006'
            -
              class: Pod::Weaver::Section::Generic
              name: '@Apocalyptic/Description'
              version: '4.006'
            -
              class: Pod::Weaver::Section::Collect
              name: '@Apocalyptic/Attributes'
              version: '4.006'
            -
              class: Pod::Weaver::Section::Collect
              name: '@Apocalyptic/Methods'
              version: '4.006'
            -
              class: Pod::Weaver::Section::Collect
              name: '@Apocalyptic/Functions'
              version: '4.006'
            -
              class: Pod::Weaver::Section::Collect
              name: '@Apocalyptic/POEvents'
              version: '4.006'
            -
              class: Pod::Weaver::Section::Leftovers
              name: '@Apocalyptic/Leftovers'
              version: '4.006'
            -
              class: Pod::Weaver::Section::SeeAlso
              name: '@Apocalyptic/SeeAlso'
              version: '1.003'
            -
              class: Pod::Weaver::Section::Support
              name: '@Apocalyptic/Support'
              version: '1.006'
            -
              class: Pod::Weaver::Section::Authors
              name: '@Apocalyptic/Authors'
              version: '4.006'
            -
              class: Pod::Weaver::Section::Contributors
              name: '@Apocalyptic/Contributors'
              version: '0.008'
            -
              class: Pod::Weaver::Section::Generic
              name: '@Apocalyptic/ACK'
              version: '4.006'
            -
              class: Pod::Weaver::Section::Legal
              name: '@Apocalyptic/Legal'
              version: '4.006'
            -
              class: Pod::Weaver::Section::WarrantyDisclaimer::GPL3
              name: '@Apocalyptic/Warranty'
              version: '0.121290'
            -
              class: Pod::Weaver::Plugin::Transformer
              name: '@Apocalyptic/ListTransformer'
              version: '4.006'
            -
              class: Pod::Weaver::Plugin::EnsureUniqueSections
              name: '@Apocalyptic/UniqueSections'
              version: '0.121550'
      name: '@Apocalyptic/PodWeaver'
      version: '4.006'
    -
      class: Dist::Zilla::Plugin::LocaleMsgfmt
      name: '@Apocalyptic/LocaleMsgfmt'
      version: '1.203'
    -
      class: Dist::Zilla::Plugin::NextRelease
      name: '@Apocalyptic/NextRelease'
      version: '5.023'
    -
      class: Dist::Zilla::Plugin::ChangelogFromGit
      name: '@Apocalyptic/ChangelogFromGit'
      version: '0.016'
    -
      class: Dist::Zilla::Plugin::MinimumPerl
      name: '@Apocalyptic/MinimumPerl'
      version: '1.005'
    -
      class: Dist::Zilla::Plugin::Bugtracker
      name: '@Apocalyptic/Bugtracker'
      version: '1.111080'
    -
      class: Dist::Zilla::Plugin::Homepage
      name: '@Apocalyptic/Homepage'
      version: '1.101420'
    -
      class: Dist::Zilla::Plugin::MetaConfig
      name: '@Apocalyptic/MetaConfig'
      version: '5.023'
    -
      class: Dist::Zilla::Plugin::Git::Contributors
      config:
        Dist::Zilla::Plugin::Git::Contributors:
          include_authors: '0'
          include_releaser: '1'
          order_by: name
          paths: []
      name: '@Apocalyptic/Git::Contributors'
      version: '0.008'
    -
      class: Dist::Zilla::Plugin::MetaData::BuiltWith
      config:
        Dist::Zilla::Plugin::MetaData::BuiltWith:
          _stash_key: x_BuiltWith
          show_config: '0'
          show_uname: '1'
          uname:
            uname_args:
              - -s
              - -r
              - -m
            uname_call: uname
      name: '@Apocalyptic/MetaData::BuiltWith'
      version: '1.003001'
    -
      class: Dist::Zilla::Plugin::Repository
      name: '@Apocalyptic/Repository'
      version: '0.20'
    -
      class: Dist::Zilla::Plugin::MetaResources
      name: '@Apocalyptic/MetaResources'
      version: '5.023'
    -
      class: Dist::Zilla::Plugin::MetaNoIndex
      name: '@Apocalyptic/MetaNoIndex'
      version: '5.023'
    -
      class: Dist::Zilla::Plugin::MetaProvides::Package
      config:
        Dist::Zilla::Plugin::MetaProvides::Package:
          finder_objects:
            -
              class: Dist::Zilla::Plugin::FinderCode
              name: '@Apocalyptic/MetaProvides::Package/AUTOVIV/:InstallModulesPM'
              version: '5.023'
        Dist::Zilla::Role::MetaProvider::Provider:
          inherit_missing: '1'
          inherit_version: '1'
          meta_noindex: '1'
      name: '@Apocalyptic/MetaProvides::Package'
      version: '2.001002'
    -
      class: Dist::Zilla::Plugin::License
      name: '@Apocalyptic/License'
      version: '5.023'
    -
      class: Dist::Zilla::Plugin::ModuleBuildTiny
      config:
        Dist::Zilla::Role::TestRunner:
          default_jobs: '1'
      name: '@Apocalyptic/ModuleBuildTiny'
      version: '0.008'
    -
      class: Dist::Zilla::Plugin::MakeMaker::Fallback
      config:
        Dist::Zilla::Role::TestRunner:
          default_jobs: '1'
      name: '@Apocalyptic/MakeMaker::Fallback'
      version: '0.014'
    -
      class: Dist::Zilla::Plugin::MetaYAML
      name: '@Apocalyptic/MetaYAML'
      version: '5.023'
    -
      class: Dist::Zilla::Plugin::MetaJSON
      name: '@Apocalyptic/MetaJSON'
      version: '5.023'
    -
      class: Dist::Zilla::Plugin::InstallGuide
      name: '@Apocalyptic/InstallGuide'
      version: '1.200005'
    -
      class: Dist::Zilla::Plugin::DOAP
      name: '@Apocalyptic/DOAP'
      version: '0.003'
    -
      class: Dist::Zilla::Plugin::Covenant
      name: '@Apocalyptic/Covenant'
      version: 0.1.0
    -
      class: Dist::Zilla::Plugin::CPANFile
      name: '@Apocalyptic/CPANFile'
      version: '5.023'
    -
      class: Dist::Zilla::Plugin::ReadmeAnyFromPod
      name: '@Apocalyptic/ReadmeAnyFromPod'
      version: '0.142470'
    -
      class: Dist::Zilla::Plugin::ReadmeAnyFromPod
      name: '@Apocalyptic/pod for github'
      version: '0.142470'
    -
      class: Dist::Zilla::Plugin::ChangeStats::Git
      name: '@Apocalyptic/ChangeStats::Git'
      version: 0.3.0
    -
      class: Dist::Zilla::Plugin::Signature
      name: '@Apocalyptic/Signature'
      version: '1.100930'
    -
      class: Dist::Zilla::Plugin::Manifest
      name: '@Apocalyptic/Manifest'
      version: '5.023'
    -
      class: Dist::Zilla::Plugin::CheckChangesHasContent
      name: '@Apocalyptic/CheckChangesHasContent'
      version: '0.006'
    -
      class: Dist::Zilla::Plugin::Git::Check
      config:
        Dist::Zilla::Plugin::Git::Check:
          untracked_files: die
        Dist::Zilla::Role::Git::DirtyFiles:
          allow_dirty:
            - README.pod
            - Changes
          allow_dirty_match: []
          changelog: Changes
        Dist::Zilla::Role::Git::Repo:
          repo_root: .
      name: '@Apocalyptic/Git::Check'
      version: '2.025'
    -
      class: Dist::Zilla::Plugin::Git::CheckFor::CorrectBranch
      config:
        Dist::Zilla::Role::Git::Repo:
          repo_root: .
      name: '@Apocalyptic/Git::CheckFor::CorrectBranch'
      version: '0.011'
    -
      class: Dist::Zilla::Plugin::Git::CheckFor::MergeConflicts
      config:
        Dist::Zilla::Role::Git::Repo:
          repo_root: .
      name: '@Apocalyptic/Git::CheckFor::MergeConflicts'
      version: '0.011'
    -
      class: Dist::Zilla::Plugin::Git::Remote::Check
      name: '@Apocalyptic/Git::Remote::Check'
      version: 0.1.2
    -
      class: Dist::Zilla::Plugin::PromptIfStale
      config:
        Dist::Zilla::Plugin::PromptIfStale:
          check_all_plugins: '1'
          check_all_prereqs: '1'
          modules: []
          phase: release
          skip: []
      name: '@Apocalyptic/PromptIfStale'
      version: '0.028'
    -
      class: Dist::Zilla::Plugin::TestRelease
      name: '@Apocalyptic/TestRelease'
      version: '5.023'
    -
      class: Dist::Zilla::Plugin::CheckPrereqsIndexed
      name: '@Apocalyptic/CheckPrereqsIndexed'
      version: '0.012'
    -
      class: Dist::Zilla::Plugin::CheckSelfDependency
      config:
        Dist::Zilla::Plugin::CheckSelfDependency:
          finder:
            - ':InstallModules'
      name: '@Apocalyptic/CheckSelfDependency'
      version: '0.007'
    -
      class: Dist::Zilla::Plugin::CheckIssues
      name: '@Apocalyptic/CheckIssues'
      version: '0.004'
    -
      class: Dist::Zilla::Plugin::ConfirmRelease
      name: '@Apocalyptic/ConfirmRelease'
      version: '5.023'
    -
      class: Dist::Zilla::Plugin::UploadToCPAN
      name: '@Apocalyptic/UploadToCPAN'
      version: '5.023'
    -
      class: Dist::Zilla::Plugin::ArchiveRelease
      name: '@Apocalyptic/ArchiveRelease'
      version: '4.00'
    -
      class: Dist::Zilla::Plugin::Git::Commit
      config:
        Dist::Zilla::Plugin::Git::Commit:
          add_files_in:
            - releases
          commit_msg: 'New CPAN release of %N - v%v%n%n%c'
          time_zone: UTC
        Dist::Zilla::Role::Git::DirtyFiles:
          allow_dirty:
            - README.pod
            - Changes
          allow_dirty_match: []
          changelog: Changes
        Dist::Zilla::Role::Git::Repo:
          repo_root: .
      name: '@Apocalyptic/Git::Commit'
      version: '2.025'
    -
      class: Dist::Zilla::Plugin::Git::Tag
      config:
        Dist::Zilla::Plugin::Git::Tag:
          branch: ~
          signed: '0'
          tag: release-1.006
          tag_format: release-%v
          tag_message: 'Tagged release-%v'
          time_zone: local
        Dist::Zilla::Role::Git::Repo:
          repo_root: .
      name: '@Apocalyptic/Git::Tag'
      version: '2.025'
    -
      class: Dist::Zilla::Plugin::Git::Push
      config:
        Dist::Zilla::Plugin::Git::Push:
          push_to:
            - origin
          remotes_must_exist: '1'
        Dist::Zilla::Role::Git::Repo:
          repo_root: .
      name: '@Apocalyptic/Git::Push'
      version: '2.025'
    -
      class: Dist::Zilla::Plugin::Clean
      name: '@Apocalyptic/Clean'
      version: '0.07'
    -
      class: Dist::Zilla::Plugin::SchwartzRatio
      name: '@Apocalyptic/SchwartzRatio'
      version: 0.2.0
    -
      class: Dist::Zilla::Plugin::FinderCode
      name: ':InstallModules'
      version: '5.023'
    -
      class: Dist::Zilla::Plugin::FinderCode
      name: ':IncModules'
      version: '5.023'
    -
      class: Dist::Zilla::Plugin::FinderCode
      name: ':TestFiles'
      version: '5.023'
    -
      class: Dist::Zilla::Plugin::FinderCode
      name: ':ExecFiles'
      version: '5.023'
    -
      class: Dist::Zilla::Plugin::FinderCode
      name: ':ShareFiles'
      version: '5.023'
    -
      class: Dist::Zilla::Plugin::FinderCode
      name: ':MainModule'
      version: '5.023'
    -
      class: Dist::Zilla::Plugin::FinderCode
      name: ':AllFiles'
      version: '5.023'
    -
      class: Dist::Zilla::Plugin::FinderCode
      name: ':NoFiles'
      version: '5.023'
    -
      class: Dist::Zilla::Plugin::FinderCode
      name: '@Apocalyptic/MetaProvides::Package/AUTOVIV/:InstallModulesPM'
      version: '5.023'
  zilla:
    class: Dist::Zilla::Dist::Builder
    config:
      is_trial: '0'
    version: '5.023'
x_author_pledge:
  version: '1'
x_authority: cpan:APOCAL
x_contributors:
  - 'Karen Etheridge <ether@cpan.org>'
  - 'Nigel Gregoire <nigelg@airg.com>'
  - 'Olivier Mengué <dolmen@cpan.org>'
  - 'Pedro Melo <melo@simplicidade.org>'