# This file was automatically generated by Dist::Zilla::Plugin::ModuleBuild v5.020.
use strict;
use warnings;

use Module::Build 0.3601;
use lib qw{inc}; use MyBuilder;

my %module_build_args = (
  "build_requires" => {
    "Math::Matrix::MaybeGSL" => "0.006",
    "Module::Build" => "0.3601"
  },
  "configure_requires" => {
    "Math::Matrix::MaybeGSL" => "0.006",
    "Module::Build" => "0.3601"
  },
  "dist_abstract" => "A NN based approach for language identification",
  "dist_author" => [
    "Alberto Simoes <ambs\@cpan.org>"
  ],
  "dist_name" => "Lingua-Identifier",
  "dist_version" => "0.01",
  "license" => "perl",
  "module_name" => "Lingua::Identifier",
  "recommends" => {},
  "recursive_test_files" => 1,
  "requires" => {
    "File::ShareDir" => 0,
    "File::Spec::Functions" => 0,
    "Math::Matrix::MaybeGSL" => "0.006",
    "Text::Ngram" => 0,
    "perl" => "5.014004",
    "strict" => 0,
    "utf8" => 0,
    "warnings" => 0
  },
  "script_files" => [
    "bin/identify_language"
  ],
  "share_dir" => {
    "dist" => "share"
  },
  "test_requires" => {
    "Test::More" => 0
  }
);


my %fallback_build_requires = (
  "Math::Matrix::MaybeGSL" => "0.006",
  "Module::Build" => "0.3601",
  "Test::More" => 0
);


unless ( eval { Module::Build->VERSION(0.4004) } ) {
  delete $module_build_args{test_requires};
  $module_build_args{build_requires} = \%fallback_build_requires;
}

my $build = MyBuilder->new(%module_build_args);

$build->create_build_script;