# This file was automatically generated by Dist::Zilla::Plugin::MakeMaker v6.012.
use strict;
use warnings;

use 5.010;

use ExtUtils::MakeMaker;

my %WriteMakefileArgs = (
  "ABSTRACT" => "Perl implementation of the Neo4j Driver API",
  "AUTHOR" => "Arne Johannessen <ajnn\@cpan.org>",
  "CONFIGURE_REQUIRES" => {
    "ExtUtils::MakeMaker" => 0
  },
  "DISTNAME" => "Neo4j-Driver",
  "LICENSE" => "artistic_2",
  "MIN_PERL_VERSION" => "5.010",
  "NAME" => "Neo4j::Driver",
  "PREREQ_PM" => {
    "Cpanel::JSON::XS" => "3.0201",
    "JSON::PP" => 0,
    "LWP::UserAgent" => 0,
    "REST::Client" => 134,
    "Try::Tiny" => 0,
    "URI" => "1.25"
  },
  "TEST_REQUIRES" => {
    "Test::Exception" => 0,
    "Test::More" => "0.96",
    "Test::Warnings" => 0
  },
  "VERSION" => "0.12",
  "test" => {
    "TESTS" => "t/*.t"
  }
);


my %FallbackPrereqs = (
  "Cpanel::JSON::XS" => "3.0201",
  "JSON::PP" => 0,
  "LWP::UserAgent" => 0,
  "REST::Client" => 134,
  "Test::Exception" => 0,
  "Test::More" => "0.96",
  "Test::Warnings" => 0,
  "Try::Tiny" => 0,
  "URI" => "1.25"
);


unless ( eval { ExtUtils::MakeMaker->VERSION(6.63_03) } ) {
  delete $WriteMakefileArgs{TEST_REQUIRES};
  delete $WriteMakefileArgs{BUILD_REQUIRES};
  $WriteMakefileArgs{PREREQ_PM} = \%FallbackPrereqs;
}

delete $WriteMakefileArgs{CONFIGURE_REQUIRES}
  unless eval { ExtUtils::MakeMaker->VERSION(6.52) };

WriteMakefile(%WriteMakefileArgs);