Author image ℕicolas ℝ.
and 1 contributors

SYNOPSIS

  # Makefile.PL
  use ExtUtils::MakeMaker::PPPort;

  WriteMakefile(
    NAME           => 'Foo::Bar',
    ...
    MIN_PPPORT_VERSION => 3.58, # optional
  );

DESCRIPTION

This module allows you to use an up to date version of ppport.h when using Devel-PPPort.

You do not need to ship an old version of `ppport.h` with your codebase.

Migration to ExtUtils::MakeMaker::PPPort

You want to remove `ppport.h` from your directory and ignore it in your version control.

  rm -f ppport.h
  echo 'ppport.h' >> .gitignore

Then you can start using `ExtUtils::MakeMaker::PPPort` instead of `ExtUtils::MakeMaker`.

BUGS

No known bugs.

Please report any bugs to GitHub Issues at https://github.com/atoomic/ExtUtils-MakeMaker-PPPort/issues.

SEE ALSO

ExtUtils::MakeMaker

Devel::PPPort

SUPPORT

You can find this documentation for this module with the perldoc command.

    perldoc ExtUtils::MakeMaker::PPPort

You can also look for information at: