Author image Van de Bugger
and 1 contributors

Changes for version v0.11.3 - 2016-12-21

  • `exclude_files` option of `Manifest::Write` used to exclude extra tests from the distribution. (`Manifest::Write` v0.9.7 is required.)
  • The bundle requires `Dist::Zilla` 5.038, because it needs `:ExtraTestFiles` file finder.
  • `CheckExtraTests` plugin dropped from the bundle because it does not work to me. It runs extra test in the unpacked distribution (there are no extra tests there) and fails. 13-lines `Hook::BeforeRelease` added instead, it runs extra tests in the built distribution.
  • Recently many `Dist::Zilla` plugins were changed: they started to generate author tests instead of release tests. Every change caused `build.t` test failure. Before I required specific versions of the test plugins to avoid test failures. Now `Manifest::Write` excludes extra tests from the manifest, so `build.t` test now does not depend on extra tests any more. Version requirement on many `Dist::Zilla` plugins dropped.
  • Tests are not skipped if `$ENV{ AUTHOR_TESTING }` is true.
  • Switch to `Dist::Zilla::Plugin::Manifest::Read` v0.5.0.
  • There is a bug in `Dist::Zilla::Plugin::Test::Version` < 1.07: it calls `Path::Class::File->new` without explicit `use` or `require` of the `Path::Class`. It was not so important in `Dist::Zilla` 5.x, because `Path::Class` was loaded by `Dist::Zilla`. However, `Dist::Zilla` 6.x does not use `Path::Class` any more, so `Dist::Zilla::Plugin::Test::Version` < 1.07 fails and causes test failure. (Some FreeBSD testers still use `Dist::Zilla::Plugin::Test::Version` 1.05 and `Dist::Zilla` 6.007.) Workaround implemented to let test pass.
  • Some tests fail due to bug in `Pod::Simple` — it munges Unicode characters (see `Dist::Zilla::Plugin::Templates::Manual`). `Pod::Simple` > 3.20 required to avoid test failure (3.28 is known to be good, (3.20..3.28) not yet tested versions of `Pod::Simple`).