Let [=inc::Foo] work in Perl v5.26+.

Starting from Perl v26.0, . is not included into @INC anymore. This breaks Dist::Zilla syntax for plugins which are located in the distribution source tree, e. g.:

    [=inc::Foo]

Being run with Perl v5.26+, dzil complains:

    Required plugin inc::Foo isn't installed.

Dist::Zilla::Plugin::lib was created specially for workarounding this issue. (I said "workarounding" not "solving" because Dist::Zilla::Plugin::lib does not help dzil authordeps --missing to work.)

The same effect can be achieved with Hook::Init one-liner.