NAME

Badge::Depot::Plugin::Perl - Perl version plugin for Badge::Depot

VERSION

Version 0.0103, released 2016-01-13.

SYNOPSIS

If used standalone:

    use Badge::Depot::Plugin::Perl;

    my $badge = Badge::Depot::Plugin::Perl->new(version => '5.8.5+');

    print $badge->to_html;
    # prints '<img src="https://img.shields.io/badge/perl-5.8.5+-brightgreen.svg" />'

If used with Pod::Weaver::Section::Badges, in weaver.ini:

    [Badges]
    ; other settings
    badge = Perl
    -perl_version = 5.8.5

DESCRIPTION

Creates a Perl version badge, like this:

This class consumes the Badge::Depot role.

ATTRIBUTES

All attributes are optional.

version

The minimum supported Perl version. If it isn't given, it looks for a prereqs/runtime/requires/perl entry in META.json and uses that.

It is set to 'unknown' if it is neither given or exists in META.json.

trailing

A string to add after the version, if the version is fetched from META.json. Defaults to +.

Not used if version is explicitly set.

custom_image_url

By default, this module shows an image from shields.io. Use this attribute to override that with a custom url. Use a %s placeholder where the version should be inserted.

SEE ALSO

SOURCE

https://github.com/Csson/p5-Badge-Depot-Plugin-Perl

HOMEPAGE

https://metacpan.org/release/Badge-Depot-Plugin-Perl

AUTHOR

Erik Carlsson <info@code301.com>

COPYRIGHT AND LICENSE

This software is copyright (c) 2016 by Erik Carlsson.

This is free software; you can redistribute it and/or modify it under the same terms as the Perl 5 programming language system itself.